Grammarly emails are being delivered with delays

Incident Report for Service Status | Grammarly

Resolved

This issue has now been resolved. Please accept our sincerest apologies for any inconvenience caused.
Posted Nov 24, 2024 - 12:47 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 24, 2024 - 11:26 PST

Update

We are continuing to investigate this issue.
Posted Nov 24, 2024 - 10:21 PST

Investigating

We are currently experiencing an issue causing a delay in the delivery of Grammarly emails to your inbox. We’re working to identify the cause and will provide an update as soon as we can.
Posted Nov 24, 2024 - 10:19 PST
This incident affected: Email delivery.