Grammarly is experiencing a service interruption
Incident Report for Service Status | Grammarly
Resolved
The issue has been resolved. Happy writing!
Posted Mar 06, 2020 - 10:59 PST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2020 - 10:58 PST
Investigating
We’re experiencing some service interruptions at the moment. Some users may have trouble resetting a password, changing an email address or setting up MFA. We’re investigating the problem and will provide an update as soon as possible.
Posted Mar 06, 2020 - 09:58 PST
This incident affected: Grammarly Editor, Grammarly's Browser Extension, Grammarly for Android, Login, Billing Service, Writing Suggestions, Plagiarism Detection, Account Management, Expert Writing Service, and Grammarly for Microsoft Office.