Grammarly is experiencing a service interruption
Incident Report for Service Status | Grammarly
Resolved
The issue has been resolved. Happy writing!
Posted Nov 25, 2020 - 08:57 PST
Investigating
We’re experiencing some service interruptions at the moment. Some users may have trouble logging in or creating accounts. We’re investigating the problem and will provide an update as soon as possible.
Posted Nov 25, 2020 - 07:44 PST
This incident affected: Grammarly Editor, Grammarly's Browser Extension, Grammarly Keyboard, Login, Billing Service, Writing Suggestions, Plagiarism Detection, Account Management, Expert Writing Service, Grammarly Editor for Windows and Mac, and Grammarly for Microsoft Office.