Issues affecting Human Proofreading service
Incident Report for Service Status | Grammarly
Resolved
The issue affecting the service has been resolved. We apologize for any inconvenience this may have caused.
Posted Dec 19, 2019 - 01:28 PST
Investigating
We’re investigating a problem that is preventing some users from viewing completed orders. We’ll provide an update as soon as we can.
Posted Dec 19, 2019 - 00:33 PST
This incident affected: Human Proofreading Service.