Grammarly is experiencing a service interruption
Incident Report for Service Status | Grammarly
Resolved
The issue has been resolved. Happy writing!
Posted Mar 17, 2020 - 23:05 PDT
Identified
We’re experiencing some service interruptions at the moment. Some users may have trouble receiving emails and SMS from Grammarly. We’ve identified the cause of the issue and are working to fix it.
Posted Mar 17, 2020 - 14:35 PDT
This incident affected: Grammarly Editor, Grammarly's Browser Extension, Grammarly for Android, Login, Billing Service, Writing Suggestions, Plagiarism Detection, Account Management, Expert Writing Service, and Grammarly for Microsoft Office.