Credit card payments are not being processed in Chrome and Edge browsers
Incident Report for Service Status | Grammarly
Resolved
This incident has been resolved.
Posted Oct 24, 2022 - 17:26 PDT
Update
We are continuing to investigate this issue.
Posted Oct 24, 2022 - 15:54 PDT
Investigating
Grammarly is experiencing a service interruption that is preventing us from processing credit card payments in Chrome and Edge browsers. We are working to find a solution as quickly as possible and will keep you updated. In the meantime, credit card payments can be made in Safari and Firefox browsers.
Posted Oct 24, 2022 - 15:49 PDT
This incident affected: Billing Service.