Issues affecting email preference management and email delivery
Incident Report for Service Status | Grammarly
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 03:57 PDT
Identified
We identified the root cause of the issue and are working on a fix. Thank you for your patience!
Posted Mar 21, 2024 - 09:38 PDT
Investigating
Some Grammarly users may experience issues managing their email preferences. We’re also experiencing an issue that prevents some emails from being sent to you. As a result, you may be temporarily unable to sign up, reset your password, or verify other account changes. We’re working to identify the cause and will provide an update as soon as we can.
Posted Mar 20, 2024 - 11:04 PDT
This incident affected: Email Preference Management and Email delivery.