Some Grammarly emails are not being delivered
Incident Report for Service Status | Grammarly
Resolved
This incident has been resolved.
Posted Nov 16, 2023 - 08:59 PST
Monitoring
Grammarly emails should now be delivered. We're monitoring the issue.
Posted Nov 16, 2023 - 08:40 PST
Investigating
Grammarly users can now access their account and subscription settings. However, some users may continue experiencing difficulties verifying their email addresses or resetting their passwords. Our team is investigating this issue and is working on a fix.
Posted Nov 16, 2023 - 07:59 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2023 - 07:44 PST
Investigating
Grammarly is experiencing a service interruption that is causing issues for users trying to access their account and subscription settings. Additionally, some users are experiencing difficulties verifying their email addresses. We are working to find a solution as quickly as possible and will keep you updated.
Posted Nov 16, 2023 - 07:17 PST
This incident affected: Billing Service, Account Management, and Email delivery.