Service interruption affecting Grammarly

Incident Report for Service Status | Grammarly

Resolved

The issue has been resolved. Happy writing!
Posted May 05, 2025 - 11:56 PDT

Monitoring

The issue with processing payments has been identified, and a fix is being implemented.
Posted May 05, 2025 - 11:51 PDT

Update

We are continuing to investigate this issue.
Posted May 05, 2025 - 11:41 PDT

Update

Grammarly is also experiencing a service interruption that is preventing us from processing payments. We are working to find a solution as quickly as possible and will keep you updated.
Posted May 05, 2025 - 10:47 PDT

Investigating

We’re currently working through a service interruption. Some users, including Grammarly Enterprise customers, may not see Grammarly suggestions or see “Something went wrong."
Posted May 05, 2025 - 09:49 PDT
This incident affected: Grammarly for Windows, Grammarly for Mac, Grammarly Editor, Grammarly's Browser Extension, Grammarly for Android, Grammarly for iPhone, Grammarly for Samsung Keyboard, Grammarly for iPad, Login, Billing Service, Writing Suggestions, Generative AI assistance, Plagiarism Detection, Account Management, Grammarly for Microsoft Office, and Grammarly for Microsoft Word on Mac.