Issues with resetting password
Incident Report for Service Status | Grammarly
Resolved
The issue has been resolved. Happy writing!
Posted Feb 21, 2024 - 15:01 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 21, 2024 - 12:16 PST
Update
We are continuing to investigate this issue.
Posted Feb 21, 2024 - 11:42 PST
Investigating
We are currently working through a service disruption. As a result, you might be temporarily unable to reset your password or log in to your account. Updates will be provided as they become available.
Posted Feb 21, 2024 - 11:36 PST
This incident affected: Grammarly Editor, Grammarly's Browser Extension, Grammarly for Android, Billing Service, Writing Suggestions, Plagiarism Detection, Account Management, Expert Writing Service, and Grammarly for Microsoft Office.