Grammarly is experiencing a service interruption

Incident Report for Service Status | Grammarly

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 09:43 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2025 - 09:37 PDT

Update

We are continuing to investigate this issue.
Posted Mar 18, 2025 - 08:55 PDT

Investigating

We’re experiencing some service interruptions at the moment. Some users may not be able to see suggestions or corrections from Grammarly. We’re investigating the problem and will provide an update as soon as possible.
Posted Mar 18, 2025 - 08:54 PDT
This incident affected: Grammarly for Windows, Grammarly for Mac, Grammarly Editor, Grammarly's Browser Extension, Grammarly for Android, Grammarly for iPhone, Grammarly for Samsung Keyboard, Grammarly for iPad, Login, Writing Suggestions, Generative AI assistance, Plagiarism Detection, Account Management, Grammarly for Microsoft Office, and Grammarly for Microsoft Word on Mac.