The plagiarism detection service is unavailable
Incident Report for Service Status | Grammarly
Resolved
Issues affecting the service have been addressed. Please accept our sincerest apologies for this service interruption.
Posted Nov 20, 2023 - 07:44 PST
Investigating
We’re experiencing a problem with our plagiarism checker at the moment. We’re working to identify the cause and will provide an update as soon as we can.
Posted Nov 20, 2023 - 07:19 PST
This incident affected: Plagiarism Detection.