Unable to log in
Incident Report for Service Status | Grammarly
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 04, 2019 - 01:15 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Sep 04, 2019 - 01:06 PDT
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Sep 04, 2019 - 01:06 PDT
Investigating
We’re currently working through a service disruption. Updates will be provided as they become available.
Posted about 1 month ago. Sep 04, 2019 - 00:26 PDT
This incident affected: MS Office Add-in and Login.