Increased latency across Grammarly product offerings

Incident Report for Service Status | Grammarly

Resolved

This issue has been resolved.
Posted Mar 09, 2026 - 13:07 PDT

Monitoring

We've implemented a fix, so you should be able to log in and use Grammarly and Superhuman. We're monitoring the results of this fix and will provide further updates.
Posted Mar 09, 2026 - 12:15 PDT

Update

We're still looking into this issue. We'll provide an update as soon as we can.
Posted Mar 09, 2026 - 11:53 PDT

Update

We're continuing to investigate this issue. Some Grammarly users may have trouble logging in or see "Service unavailable" when trying to use Grammarly.
Posted Mar 09, 2026 - 10:21 PDT

Investigating

We are currently investigating an issue causing Grammarly's product offerings and features to work intermittently or slower than usual. We will update you as soon as we have more information. Thank you for your patience!
Posted Mar 09, 2026 - 09:52 PDT
This incident affected: Grammarly for Windows, Grammarly for Mac, Grammarly Editor, Grammarly's Browser Extension, Grammarly for Android, Grammarly for iPhone, Grammarly for iPad, Login, Writing Suggestions, Generative AI assistance, Plagiarism Detection, Grammarly for Microsoft Office, and Grammarly for Microsoft Word on Mac.