Unable to delete accounts
Incident Report for Service Status | Grammarly
Resolved
This incident has been resolved.
Posted Nov 21, 2020 - 11:17 PST
Investigating
We are currently working through a service disruption. As a result, you might be temporarily unable to delete your account. Updates will be provided as they become available.
Posted Nov 21, 2020 - 10:49 PST
This incident affected: Account Management.