The service has recovered, and we're still monitoring the issue.
Posted Dec 03, 2024 - 08:48 PST
Investigating
We’re currently working through a service disruption that is preventing our users from accessing and managing their account preferences. Some users also reported issues with the Grammarly Editor. We apologize for any inconvenience, and updates will be provided as they become available.
Posted Dec 03, 2024 - 08:22 PST
This incident affected: Grammarly Editor, Account Management, and Email Preference Management.