Amazon has resolved the CloudFront service outage, and our services are back to normal.
Posted Jul 16, 2026 - 06:12 PDT
Monitoring
We introduced temporary changes to mitigate this issue during CloudFront's outage. Access to Grammarly via superhuman.com should now be restored. We are monitoring the results.
Posted Jul 16, 2026 - 02:10 PDT
Identified
We have identified an issue affecting access to Grammarly services via superhuman.com.
This may be related to a temporary Amazon CloudFront outage.
We apologize for any inconvenience, and updates will be provided as they become available.