Grammarly Business is experiencing a service interruption: issue identified
Incident Report for Service Status | Grammarly
Resolved
This incident has been resolved.
Posted Jun 30, 2021 - 12:32 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 30, 2021 - 11:58 PDT
This incident affected: Grammarly Editor, Grammarly's Browser Extension, Grammarly Keyboard, Login, Billing Service, Writing Suggestions, Plagiarism Detection, Account Management, Expert Writing Service, Grammarly Editor for Windows and Mac, and Grammarly for Microsoft Office.