Support contact form is down
Incident Report for Service Status | Grammarly
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 24, 2019 - 03:05 PDT
Identified
There’s a problem with our contact form at the moment. In the meantime, you can browse the knowledge base while we're investigating this issue.
Posted 3 months ago. Jul 24, 2019 - 02:41 PDT
This incident affected: Helpdesk (support.grammarly.com).