Grammarly verification and sign-up emails may not be delivered
Incident Report for Service Status | Grammarly
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 16:27 PST
Investigating
We’re currently experiencing an issue that prevents verification emails from being sent to you. As a result, you may be temporarily unable to sign up, reset your password, or verify other account changes. We’re working to identify the cause and will provide an update as soon as we can. In the meantime, please log in using social sign-in options like Google, Apple, and Facebook.
Posted Dec 15, 2023 - 15:11 PST
This incident affected: Account Management and Email delivery.