Removing members from your organization’s account may be delayed

Incident Report for Service Status | Grammarly

Resolved

The issue is resolved. Grammarly is up and running
Posted Mar 08, 2025 - 01:39 PST

Monitoring

A fix has been implemented, and we are monitoring the results. Delays should soon be minimized.
Posted Mar 07, 2025 - 22:03 PST

Update

We are continuing to work on a fix for this issue.
Posted Mar 07, 2025 - 12:19 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 07, 2025 - 10:19 PST

Investigating

You may experience delays when removing members from your organization’s account. Removed members may also still appear in the list for longer than expected. This does not affect individuals deleting their accounts. Our team is actively investigating the issue. Updates will be provided as they become available.
Posted Mar 07, 2025 - 09:30 PST
This incident affected: Account Management.