Issues affecting the “Forgot email?” button
Incident Report for Service Status | Grammarly
Resolved
We are happy to confirm that the issue has been resolved. We apologize for any inconvenience this may have caused.
Posted Jan 25, 2019 - 06:41 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 25, 2019 - 06:35 PST
Investigating
We’re investigating a problem affecting the “Forgot email?” button. Our engineers are looking into the cause and will have updates shortly.
Posted Jan 25, 2019 - 05:53 PST
This incident affected: Grammarly Editor.