Email delivery
Incident Report for Service Status | Grammarly
Resolved
This incident has been resolved.
Posted 5 days ago. Oct 09, 2019 - 11:41 PDT
Monitoring
Some Grammarly emails may be delayed. We have identified the issue and will provide an update as soon as we can.
Posted 5 days ago. Oct 09, 2019 - 08:31 PDT
This incident affected: Account Management.