The Grammarly Editor is not working as expected

Incident Report for Service Status | Grammarly

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 00:26 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 11, 2025 - 23:46 PDT

Identified

We are currently experiencing a service interruption that may cause the Grammarly Editor to be slow or unresponsive. Some users may also have trouble connecting to Grammarly or using Grammarly Authorship. The team identified the root cause of the issue and is working on a fix. Apologies for the service interruption!
Posted Aug 11, 2025 - 22:47 PDT
This incident affected: Grammarly Editor and Snippets and Knowledge Share.