Payments are not being processed

Incident Report for Service Status | Grammarly

Resolved

This incident has been resolved.
Posted Jul 28, 2022 - 12:42 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 28, 2022 - 12:27 PDT

Investigating

Grammarly is experiencing a service interruption that is preventing us from processing payments. We are working to find a solution as quickly as possible and will keep you updated.
Posted Jul 28, 2022 - 12:25 PDT
This incident affected: Billing Service.