Some Grammarly emails may not be delivered

Incident Report for Service Status | Grammarly

Resolved

This incident has been resolved.
Posted Oct 04, 2021 - 14:53 PDT

Investigating

We’re currently experiencing an issue that prevents certain emails from being sent to you. As a result, you might be temporarily unable to reset your password or verify account changes.
Posted Oct 04, 2021 - 08:20 PDT
This incident affected: Email delivery.