A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2025 - 07:24 PDT
Identified
We’ve received reports that some users are unable to access, create, or download documents. Some users are also experiencing login issues. We’re actively investigating and will provide an update as soon as possible. Thank you for your patience.
Posted Apr 29, 2025 - 07:19 PDT
This incident affected: Grammarly Editor and Login.