Issues affecting the Business and EDU admin panels
Incident Report for Service Status | Grammarly
Resolved
We are happy to confirm that the issue has been resolved. We apologize for any inconvenience this may have caused.
Posted 7 months ago. Mar 11, 2019 - 00:42 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 7 months ago. Mar 11, 2019 - 00:38 PDT
Update
We are continuing to investigate this issue.
Posted 7 months ago. Mar 10, 2019 - 23:55 PDT
Investigating
We’re investigating an issue affecting the Business and EDU admin panels. Our engineers are looking into the cause and will have updates shortly.
Posted 7 months ago. Mar 10, 2019 - 23:45 PDT
This incident affected: Account Management.